Npm 中的版本号规则

Npm 中的版本号规则

版本格式

major.minor.patch => 主版本号.次版本号.修订版本号

版本匹配规则

version

必须匹配某个版本

如:1.1,表示必须使用 1.1 版

>version

必须大于或等于某个版本

如:>=1.1,表示可以等于1.1,也可以大于1.1版本

<version

必须小于或等于某个版本

如:<=1.1,表示可以等于1.1,也可以小于1.1版本

~version

匹配某个版本

如果 minor 版本号指定了,那么 minor 版本号不变,而 patch 版本号任意

如果 minor 和 patch 版本号未指定,那么 minor 和 patch 版本号任意

如:~1.1.2,表示 >= 1.1.2 < 1.2.0,可以是 1.1.2, 1.1.3, 1.1.4, …., 1.1.n

如:~1.1,表示 >= 1.1.0 < 1.2.0,可以是 1.1.2, 1.1.3, 1.1.4, …., 1.1.n

如:~1,表示 >= 1.0.1 < 2.0.0,可以是 1.0.0, 1.0.1, 1.0.2, 1.1.n, 1.2.n

^version

兼容某个版本

版本号中最左边的非0数字的右侧可以任意

如果缺少某个版本号,这个版本号的位置可以任意

如:^1.1.2 ,表示 >=1.1.2 < 2.0.0,可以是 1.1.2,1.1.3,…..,1.1.n,1.2.n,…..,1.n.n

如:^0.2.3 ,表示 >=0.2.3 < 0.3.0,可以是 0.2.3,0.2.4,…..,0.2.n

如:^0.0,表示 >=0.0.0 < 0.1.0,可以是 0.0.0,0.0.1,…..,0.0.n

x标识符

x 的位置标示任意版本

如:1.2.x,表示可以 1.2.0, 1.2.1, …, 1.2.n

*标识符

任意版本

如:*,表示 >= 0.0.0 的任意版本

version1 - version2

大于等于 version,小于等于 version2

如:1.1.2 - 1.3.1,表示包括 1.1.2 和 1.3.1 以及他们之间的任意版本

range1 || range2

满足 range1 或者满足 range2,可以是多个范围

如:<1.0.0 || >= 2.3.1 <2.4.5 || >= 2.5.2 <3.0.0

install和update区别

The difference between npm install and npm update handling of package versions specified in package.json:

1
2
3
4
5
6
7
8
9
10
11
12
{
"name": "my-project",
"version": "1.0", // install update
"dependencies": { // ------------------
"already-installed-versionless-module": "*", // ignores "1.0" -> "1.1"
"already-installed-semver-module": "^1.4.3" // ignores "1.4.3" -> "1.5.2"
"already-installed-versioned-module": "3.4.1" // ignores ignores
"not-yet-installed-versionless-module": "*", // installs installs
"not-yet-installed-semver-module": "^4.2.1" // installs installs
"not-yet-installed-versioned-module": "2.7.8" // installs installs
}
}

总结: 两者最大的区别是在对待已经安装过的模糊版本时候

  • npm install会忽略模糊版本
  • npm update会更新模糊版本至最新

另外: install and update 处理 devDependencies 方式也不同

  • npm install 会安装/更新devDependencies,除非你指定 –production标志
  • npm update 会忽略 devDependencies,除非你指定 –dev 标志

来自 https://stackoverflow.com/questions/12478679/npm-install-vs-update-whats-the-difference

原文:https://my.oschina.net/yidao620c/blog/2989842